Capítulo 16. Menus

Índice

1. Introdução aos menus
1.1. A barra de menu de imagem
1.2. Menus de contexto
1.3. Submenus destacáveis
1.4. Abas de menus
2. O menu “Arquivo”
2.1. Visão geral
2.2. New
2.3. Create
2.4. Open
2.5. Open as Layers
2.6. Open Location
2.7. Open Recent
2.8. Save
2.9. Save as
2.10. Save a Copy
2.11. Revert
2.12. Export
2.13. Export As...
2.14. Create Template
2.15. Print
2.16. Close
2.17. Close all
2.18. Quit
3. O menu “Editar”
3.1. “Edit” Menu Entries
3.2. Undo
3.3. Redo
3.4. Fade
3.5. Undo History
3.6. Cut
3.7. Copy
3.8. Copy Visible
3.9. Paste
3.10. Paste Into
3.11. Paste as
3.12. Buffer
3.13. Clear
3.14. Fill with FG Color
3.15. Fill with BG Color
3.16. Fill with Pattern
3.17. Stroke Selection
3.18. Stroke Path
3.19. The “Preferences” Command
3.20. Keyboard Shortcuts
3.21. Modules
3.22. Units
4. O menu “Selecionar”
4.1. Introdução ao menu “Selecionar”
4.2. Select All
4.3. None
4.4. Invert
4.5. Float
4.6. By Color
4.7. From Path
4.8. Selection Editor
4.9. Feather
4.10. Sharpen
4.11. Shrink
4.12. Grow
4.13. Border
4.14. Distort
4.15. Rounded Rectangle
4.16. Toggle QuickMask
4.17. Save to Channel
4.18. To Path
5. O menu “visualizar”
5.1. Introduction to the “View” Menu
5.2. New View
5.3. Dot for Dot
5.4. Zoom
5.5. Shrink Wrap
5.6. Full Screen
5.7. Navigation Window
5.8. Display Filters
5.9. Show Selection
5.10. Show Layer Boundary
5.11. Show Guides
5.12. Show Grid
5.13. Show Sample Points
5.14. Snap to Guides
5.15. Snap to Grid
5.16. Snap to Canvas
5.17. Snap to Active Path
5.18. Padding Color
5.19. Show Menubar
5.20. Show Rulers
5.21. Show Scrollbars
5.22. Show Statusbar
6. O menu “Imagem”
6.1. Overview
6.2. Duplicate
6.3. Mode
6.4. RGB mode
6.5. Grayscale mode
6.6. Indexed mode
6.7. Transform
6.8. Flip Horizontally; Flip Vertically
6.9. Rotation
6.10. Guillotine
6.11. Canvas Size
6.12. Fit Canvas to Layers
6.13. Fit Canvas to Selection
6.14. Print Size
6.15. Scale Image
6.16. Crop to Selection
6.17. Autocrop Image
6.18. Zealous Crop
6.19. Merge Visible Layers
6.20. Flatten Image
6.21. Align Visible Layers
6.22. Guides
6.23. New Guide
6.24. New Guide (by Percent)
6.25. New Guides from Selection
6.26. Remove all guides
6.27. Configure Grid
6.28. Image Properties
7. O menu “Camada”
7.1. Introduction to the “Layer” Menu
7.2. New Layer
7.3. New Layer Group
7.4. New From Visible
7.5. Duplicate layer
7.6. Anchor layer
7.7. Merge Down
7.8. Delete Layer
7.9. The Text Commands of the Layer Menu
7.10. Discard Text Information
7.11. “Stack” Submenu
7.12. Select Previous Layer
7.13. Select Next Layer
7.14. Select Top Layer
7.15. Select Bottom Layer
7.16. Raise Layer
7.17. Lower Layer
7.18. Layer to Top
7.19. Layer to Bottom
7.20. The “Reverse Layer Order” command
7.21. The “Mask” Submenu
7.22. Add Layer Mask
7.23. Apply Layer Mask
7.24. Delete Layer Mask
7.25. Show Layer Mask
7.26. Edit Layer Mask
7.27. Disable Layer Mask
7.28. Mask to Selection
7.29. Add Layer Mask to Selection
7.30. Subtract Layer Mask from Selection
7.31. Intersect Layer Mask with Selection
7.32. The “Transparency” Submenu of the “Layer” menu
7.33. Add Alpha Channel
7.34. Remove Alpha Channel
7.35. Color to Alpha
7.36. Semi-flatten
7.37. Threshold Alpha
7.38. Alpha to Selection
7.39. Add Alpha channel to Selection
7.40. Subtract from Selection
7.41. Intersect Alpha channel with Selection
7.42. The “Transform” Submenu
7.43. Flip Horizontally
7.44. Flip Vertically
7.45. Rotate 90° clockwise
7.46. Rotate 90° counter-clockwise
7.47. Rotate 180°
7.48. Arbitrary Rotation
7.49. Offset
7.50. Layer Boundary Size
7.51. Layer to Image Size
7.52. Scale Layer
7.53. Crop to Selection
7.54. Autocrop Layer
8. O menu “Cores”
8.1. Introduction to the “Colors” Menu
8.2. Colors Tools
8.3. Invert
8.4. Value Invert
8.5. Use GEGL
8.6. The “Auto” Submenu
8.7. Equalizar
8.8. Equilibrio de branco
8.9. Realce de cor
8.10. Normalizar
8.11. Esticar contraste
8.12. Esticar HSV
8.13. The “Components” Submenu
8.14. Misturador de Canais
8.15. Compor
8.16. Decompor
8.17. Recompor
8.18. The “Map” Submenu
8.19. Rearranja o mapa de cores
8.20. Especifica o mapa de cores
8.21. Mapeamento alien
8.22. Troca de cores
8.23. Mapear com degradê
8.24. Mapear com paleta
8.25. Rotaciona cores
8.26. Colorizar a partir de amostra
8.27. The “Info” Submenu
8.28. Histograma
8.29. Média da borda
8.30. Análise do cubo de cores
8.31. Paleta suave
8.32. The Color Filters
8.33. Colorify
8.34. Color to Alpha
8.35. Filter Pack
8.36. Hot
8.37. Max RGB
8.38. Retinex
9. O menu “Ferramentas”
9.1. Introdução ao menu “Ferramentas”
10. O menu “Filtros”
10.1. Introduction to the “Filters” Menu
10.2. Repeat Last
10.3. Re-show Last
10.4. Reset All Filters
10.5. The “Python-Fu” Submenu
10.6. The “Script-Fu” Submenu
11. Menu “Janelas”
12. O menu “Ajuda”
12.1. Introdução ao menu “Ajuda”
12.2. Help
12.3. Context Help
12.4. Tip of the Day
12.5. About
12.6. Plug-In Browser
12.7. The Procedure Browser
12.8. GIMP online

1. Introdução aos menus

Existem diversos lugares no GIMP em você pode encontrar menus. O objetivo desse capítulo é descrever todos os comandos que são acessíveis a partir da barra de menu da janela de imagem e do menu de imagem que aparece ao clicar com o botão direito na tela. Todos os menus de contexto e menus de outros diálogos são descritos nos demais capítulos, que são focados em descrever os diálogos em si.

1.1. A barra de menu de imagem

Essa barra de menu pode conter outras entradas caso você tenha adicionado extensões e filtros ao seu GIMP, tais como scripts feitos em script-fu ou Python ou a extensão de vídeos (GAP).

1.2. Menus de contexto

Se você clicar com o botão direito em certas partes da interface do GIMP, aparece um “menu de contexto”, que pode apresentar várias funções. Alguns lugares onde você pode acessar os menus contextuais são:

  • Ao clicar sobre a janela de imagem, aparece o menu de imagem. Isso é útil ao se trabalhar no modo de janela cheia, sem a barra de menus. Esse menu é uma cópia do menu na barra da janela de imagens.

  • Ao clicar sobre uma camada na janela de camadas ou em um canal na janela de canais exibe funções para a camada ou canal selecionado.

  • Clicar com o botão direito do mouse na barra de menu da janela de imagem tem o mesmo efeito que clicar com o botão esquerdo.

  • Clicar com o botão direito do mouse na barra de título mostra funções que não pertencem ao GIMP, mas ao programa gerenciador de janelas de do seu computador.

1.3. Submenus destacáveis

Existe uma propriedade interessante associada com alguns dos menus do GIMP. Aqui estão alguns dos menus de imagem de contexto que você consegue obter ao clicar com o botão direito sobre a tela ou sobre qualquer um dos submenus. (Você pode entender que o item de menu leva a um submenu quando existe um ícone próximo a ele.) Quando você abre qualquer um desses menus, existe uma linha pontilhada no topo do menu (linha de separação). Ao clicar sobre essa linha pontilhada, você destaca o menu abaixo deste e ele se torna uma janela em separado.

Figura 16.1. O submenu “janelas” e seu submenu destacável

O submenu “janelas” e seu submenu destacável
O submenu “janelas” e seu submenu destacável

Os menus separáveis são realmente independentes. Eles são sempre visíveis, e suas funções sempre se aplicam a imagem atual, e eles continuam abertos quando todas as imagens são fechadas. Você pode fechar um submenu separável ao clicar sobre a linha pontilhada novamente ou fechando a janela pelo gerenciador de janelas do seu computador (geralmente ao se clicar no ícone de X no canto superior direito da janela).

Esses submenus destacáveis também podem ser criados no modo de janela única, mas são muito menos interessantes já que ficam atrás da janela principal uma vez que você clica nela.

1.4. Abas de menus

O seguinte tipo de menu não está relacionado à barra de menu da janela de imagem, mas para é importante mencionar:

Toda janela encaixável contém um botão de menu das guias (abas), como destacado abaixo. Pressionar o botão de menu das guiasabre um menu especial de operações relacionadas aos diálogos de encaixe, com uma entrada no topo que abre o menu de contexto do diálogo de encaixe visível.

Figura 16.2. Um diálogo de encaixe

Um diálogo de encaixe

Uma janela de diálogo com o botão de aba de menu destacado.

Um diálogo de encaixe

O menu de guias


Veja Seção 2.3.2, “Menu das Abas (guias)” para aprender mais sobre menus de guias